Jump to content

Rexyyoxxx

Member Since 04 Mar 2014
Offline Last Active Dec 28 2016 10:47 PM
*****

Topics I've Started

dk dot broken

30 October 2016 - 11:02 PM

dk dot keeps making u enter combat and sit up so u cant drink in arena, why arent bugs like this fixed in testing. piece of shit game, not only do u have pets to keep u in combat, but this stupid bug.

 

yes im mad

 

 

yours,

 

rogue mage in 2s


3k enhance (cata) 2.9 wod

10 July 2016 - 08:51 PM

enhance lf tubo 2600 cr or got one 2500 cr, not played since like... february? played on an off recently so not rusty, however ive never played rdruid turbo seriously, only ever played hpala/disc/mweaver

be nice to get glad again this season as I didnt play last season, my 2.6 is from the start of the season and not played my main enhance. I have a warrior friend who we got glad together a few times and communicate well, but for the life of me we cant find a healer anywhere.

I hate turbo as much as everyone else and hate how enhance has become fotm, so i can be hipster and try other comps i dont mind

from the UK and warrior is dutch


btag: may#21830

So I got alpha...

01 April 2016 - 06:19 PM

y I got alpha unknowingly, so i decided to play what I always play... enhance shaman.

they've removed like 50% of my buttons i have 8 buttons give or take 2/3 focus macros and my rotation is all about keeping up buffs, and i have one button that does significant damage (stormstrike)

The class feels so shit however I do like the whole projecting totem things, but Is it me or have we lost our elementals as enhance? I feel like i havent unlocked half my abilities or something.. I will update this as i go along

Earth shield bug

04 March 2016 - 10:21 PM

http://imgur.com/koLLSUD

same as beacon of light bug, seemed to work when i swapped earth shield while the mage was in stealth and los of me?

Razer Naga Chroma Help

04 March 2016 - 04:11 PM

k, so I bought a razer naga chroma after having the old razer naga for like 8 years? inb4 swifty. the old one was awesome but the clicks eventually went after I repaired it 5+ times. Anyway. My Razer naga chroma, wired/wireless (always in wired) randomly crashes wether its wireless or wired, and I have to unplug / plug it in and take it out/plug in again to make it work. I searched literally everywhere and there was another guy on MMO champion with exact same thing and he got no reply. I feel like its conflicting with my logitech g930 headset in a way? because in device manager when this happens my mouse turns up as a headset and vice versa...

I uninstalled drivers and everything before it gets suggested. And I was told to calibrate, but the chroma comes with no calibration in synapse which is stupid as fk as its more expensive...

<