Jump to content

Photo

Frames Disappearing upon Shadowfiend / Mindbender


  • Please log in to reply
4 replies to this topic

#1 Rekompense

Rekompense
  • LocationCST

Posted 05 June 2016 - 05:57 AM

Has anyone else encountered this? I don't use many addons, so I'm having trouble identifying where it's coming from.

Note: to be specific, it's my party frames. I use the Raid style option.

Here are the addons I use:
* sArena
* Recount
* OmniBar
* TrufiGCD

I also run the following UI scripts:

Class Icons 1
/run UFP="UnitFramePortrait_Update" UICC="Interface\\TargetingFrame\\UI-Classes-Circles" CIT=CLASS_ICON_TCOORDS UC=UnitClass
/run PaladinPowerBar:ClearAllPoints();PaladinPowerBar:SetPoint("CENTER",UIParent,"CENTER",0,-300)

Class Icons 2

/run hooksecurefunc(UFP,function(self) if self.portrait then t=CIT[select(2,UC(self.unit))] if t and UnitIsPlayer(self.unit) then self.portrait:SetTexture(UICC) self.portrait:SetTexCoord(unpack(t)) else self.portrait:SetTexCoord(0,1,0,1) end end end)

Expanded Debuffs 1

/run CBT="CompactDebuffTemplate";function mb(ff3) for p=7,12 do ff3.debuffFrames[p]:ClearAllPoints();ff3.debuffFrames[p]:SetPoint("BOTTOMRIGHT", ff3.debuffFrames[p-3], "TOPRIGHT", 0, 0) end end;

Expanded Debuffs 2

/run function CBF(pr,i) bf=CreateFrame("Button",pr:GetName().."Debuff"..i,pr,CBT);bf.baseSize=22;end;function mv(u) mb(u);for k=4,6 do f2=u.debuffFrames[k];f2:ClearAllPoints();f2:SetPoint("TOPRIGHT", u.debuffFrames[1], "TOPRIGHT", -(22*(k-3)), 0) end end

Expanded Debuffs 3

/run function mv3(t) CompactUnitFrame_SetMaxDebuffs(t,12); if(not t.debuffFrames[4]) then for j=4,12 do CBF(t,j) end end mv(t) end;hooksecurefunc("CompactUnitFrame_UpdateDebuffs",function(f) mv3(f) end);


Any ideas?

Help would be very much appreciated. You can see why losing party frames as a healer in arena would be pretty terrible.

Best regards,
Rek

Edited by Rekompense, 05 June 2016 - 05:58 AM.

  • 0

#2 Rekompense

Rekompense
  • LocationCST

Posted 05 June 2016 - 06:24 AM

Confirmed it happens with all addons off. Trying to test without the UI scripts.

Edited by Rekompense, 05 June 2016 - 06:43 AM.

  • 0

#3 Rekompense

Rekompense
  • LocationCST

Posted 05 June 2016 - 07:48 AM

It seems to be connected to the Expanded Debuffs UI script, as it is not happening with the Class Icons script. Any UI/LUA experts that can help me out?
  • 0

#4 Xonika

Xonika
  • Junkies
  • Humanclass_name
  • EU-Aegwynn
  • Blutdurst
  • Posts: 976
  • Talents: Retribution 1/0/0/2/0/2/2
  • 2v2: 1368
  • 3v3: 3096
  • 5v5: 288
  • RBG: 1795

Posted 05 June 2016 - 11:37 AM

no1 believed me it happened during qualifiers, reasoning for it was the debuff scripts from cdew's stream
  • 1

#5 Ventux

Ventux
  • Junkies
  • Undeadclass_name
  • EU-Stormscale
  • Cyclone / Wirbelsturm
  • Posts: 441
  • Talents: Frost

Posted 05 June 2016 - 01:15 PM

no1 believed me it happened during qualifiers, reasoning for it was the debuff scripts from cdew's stream


cdew sabotaged u class envy confirmed

Edited by Ventux, 05 June 2016 - 01:16 PM.

  • 1




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

<