Jump to content

Photo

Recent Glad Helmets Not Displaying

helmet gladiator glad

  • Please log in to reply
3 replies to this topic

#1 Wolfypoo

Wolfypoo
  • Junkies
  • Humanclass_name
  • US-Tichondrius
  • Bloodlust
  • Posts: 6
  • Talents: Survival 0/1/2/2/0/0/0
  • 2v2: 480

Posted 03 April 2014 - 06:34 PM

Just wondering if anyone else is having trouble getting their glad helmets to display on their forum posts. I should have s13 and s14 helmets :confused:.
  • 0

#2 Mattadoro

Mattadoro
  • Junkies
  • Humanclass_name
  • US-Mannoroth
  • Ruin
  • Posts: 2,211
  • Talents: Marksmanship 0/1/2/2/0/2/.
  • 2v2: 2090
  • 3v3: 2769
  • 5v5: 2517
  • RBG: 767
  • LocationGAINSville, The Gym

Posted 03 April 2014 - 07:01 PM

they are just being classist against you

#hunterproblems
  • 1
Posted Image

#3 dominera

dominera
  • Junkies
  • Humanclass_name
  • EU-Outland
  • Misery
  • Posts: 219
  • Talents: Frost 0/0/0/2/1/2
  • 2v2: 2055
  • 3v3: 2256
  • 5v5: 768
  • RBG: 1684
  • LocationSweden

Posted 03 April 2014 - 07:11 PM

There is actually a thread in the site feedback forum solely for this discussion. Why dont you write there instead as intended?

You will get help there, for example you could try to:

Completely relog
Armory update
Delete ur char and reapply it
etc
  • 0

#4 Vanguards

Vanguards
  • Administrators
  • Blood Elfclass_name
  • US-Tichondrius
  • Bloodlust
  • Posts: 1,401
  • Talents: Retribution 0/1/0/1/1/0/1
  • 2v2: 96
  • 3v3: 2292

Posted 03 April 2014 - 07:14 PM

Moved. Definitely try what Foxztar posted first.
  • 0
http://twitch.tv/VanguardsTV- Stream (Follow to know when I'm live!)
http://twitter.com/VanguardsTV- Twitter
http://facebook.com/Samk920 - Facebook

http://youtube.com/SamK920 - YouTube Videos





Also tagged with one or more of these keywords: helmet, gladiator, glad

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

<