Jump to content

  • Curse Sites
Help

Problem with ArenaEnemyFrames ClassIcons and MoveAnything


  • Please log in to reply
4 replies to this topic

#1

Posted 06 July 2013 - 10:24 AM

I want to move my Arena Enemy Frames like in this VOD ht tp://www.twitch.tv/pyrocta/b/426121875
The problem is that after every stealth of the enemy team, the Class Icon disappears like in this Video(1:10min/2:50min). Can someone fix this :D?

#2 baggylol

baggylol
  • Members
  • Humanclass_name
  • EU-Outland
  • Misery
  • Posts: 53
  • Talents: Marksmanship 1/0/1/0/1/0
  • RBG: 192

Posted 07 July 2013 - 09:21 AM

Delete WTF folder and reinstall addon? or try just updating it

#3

Posted 07 July 2013 - 09:55 AM

already tested, still does not work

#4 Synchrone

Synchrone
  • Junkies
  • Blood Elfclass_name
  • EU-Archimonde
  • Cataclysme / Cataclysm
  • Posts: 7
  • Talents: Retribution 1/0/0/2/0/0
  • RBG: 2411

Posted 07 July 2013 - 10:15 AM

arenajunk...ult-ui-scripts/

Quote

Quote

LoadAddOn("Blizzard_ArenaUI")--You only need to run this once.You can safely delete any copies of this line.

ArenaEnemyFrame1:ClearAllPoints()
ArenaEnemyFrame2:ClearAllPoints()
ArenaEnemyFrame3:ClearAllPoints()
ArenaEnemyFrame4:ClearAllPoints()
ArenaEnemyFrame5:ClearAllPoints()

ArenaEnemyFrame1:SetPoint("CENTER",UIParent,"CENTER",350,50)
ArenaEnemyFrame2:SetPoint("CENTER",UIParent,"CENTER",350,0)
ArenaEnemyFrame3:SetPoint("CENTER",UIParent,"CENTER",350,-50)
ArenaEnemyFrame4:SetPoint("CENTER",UIParent,"CENTER",350,-100)
ArenaEnemyFrame5:SetPoint("CENTER",UIParent,"CENTER",350,-150)

ArenaEnemyFrame1.SetPoint = function() end
ArenaEnemyFrame2.SetPoint = function() end
ArenaEnemyFrame3.SetPoint = function() end
ArenaEnemyFrame4.SetPoint = function() end
ArenaEnemyFrame5.SetPoint = function() end
Frames have to be moved separately now. ClearAllPoints and blanketing the SetPoint method are both mandatory now for it to work properly. The only way to fit this in a macro is to loop it, I'll add this in later.



#5

Posted 07 July 2013 - 08:21 PM

Fixed the problem with this 4 Scripts.

/run LoadAddOn("Blizzard_ArenaUI") ArenaEnemyFrames:Show() ArenaEnemyFrame1:Show() ArenaEnemyFrame2:Show() ArenaEnemyFrame3:Show() ArenaEnemyFrame1CastingBar:Show() ArenaEnemyFrame2CastingBar:Show() ArenaEnemyFrame3CastingBar:Show()


/run ArenaEnemyFrame1:SetScale(1.5)
/run ArenaEnemyFrame2:SetScale(1.5)
/run ArenaEnemyFrame3:SetScale(1.5)


/run TR="TOPRIGHT" ArenaEnemyFrame1:ClearAllPoints() ArenaEnemyFrame2:ClearAllPoints() ArenaEnemyFrame3:ClearAllPoints() ArenaEnemyFrame1:SetPoint(TR,-480,-230) ArenaEnemyFrame2:SetPoint(TR,-330,-230) ArenaEnemyFrame3:SetPoint(TR,-180,-230)


/run ArenaEnemyFrame1.SetPoint = function() end ArenaEnemyFrame2.SetPoint = function() end ArenaEnemyFrame3.SetPoint = function() end




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

<