Jump to content

UPDATED: Character Verification System Down


UPDATE 3 (5/7/2011) - Getting reports that people can add characters at this time. Please try adding your character now.

UPDATE 2: Clearly something isn't working for most folks - we're checking it out. Thanks for bearing with us.

UPDATE: I'm told the character claim system is up and running, please try to add your character now. If you continue to have trouble, please send me a screenshot of the claims screen as well as a link to your bnet and we'll try to work through it. Thanks.

I've been getting a lot of PMs and requests in Site Feedback about adding characters, so I figured I would address it here rather than trying to respond individually - <strong class='bbc'>currently the system is down</strong>! Unfortunately, our developers have been without power for the last few days because of the storms and tornadoes in the south east.

Hopefully they will get power restored and be back online soon! I'll keep this thread updated with any new information. Thanks for your patience with this issue. We'll have it back up as soon as we can!

Click here to view the article
  • 0


68 Comments

fuck tornadoes
    • 1
Huntsville got globalled :(
    • 0
druids....
    • 0
l2dodge squall line imo
    • 0
( - ;
    • 0
It keeps saying the same thing for some time now. "Please wait while your character is populated from the Battle.net Armory! This should only take a couple minutes" I will send a print later and pm you my bnet.
    • 8
Same as Liuvatar
    • 0
same me too... gets down to -4minutes and then just fades (=
    • 0
Please wait while your character is populated from the Battle.net Armory! This should only take a couple minutes.
im still stuck on this phase
    • 0
Same as everybody else it seems.
    • 0
We're looking into it. Sorry guys. Thanks for bearing with us!
    • 0
Heyho, same problem here Avanism EU Eredar
    • 0
check for who it works for and for who it doesnt, Maybe its a Eu/Us thing
    • 0
been doing this to me for like a week and a half now trying to get my toons on here
    • 0
Still nothing unfortunately :<
    • 0
Yeah, we're trying to figure it out! Hopefully I'll have a status update today sometime.
    • 0
still not working...
    • 0
sigh
    • 0
yo dawg wana get a fix in real quick?
    • 0
now working, just verified and everything went through quickly.. try now.
    • 0
you've got it almost working; it dosnt just say blalalal updating and never updates, it actually updates now and asks me to take a peice of my gear off and on the wow armory it's genuinly off then i click finnished, please verify nothing happens, click it again, nothing happens then click on "armory update" then it gives me a board message or somthing "sorry but this has been updated in the past 24 hours come back later" gg
    • 0

you've got it almost working; it dosnt just say blalalal updating and never updates, it actually updates now and asks me to take a peice of my gear off and on the wow armory it's genuinly off then i click finnished, please verify nothing happens, click it again, nothing happens then click on "armory update" then it gives me a board message or somthing "sorry but this has been updated in the past 24 hours come back later" gg


Had the same
    • 0
My "Finished, please verify me" button isnt there at all.
    • 0
I'm still not getting past "Please wait while your character is populated from the Battle.net Armory! This should only take a couple minutes".
    • 0
Scratch that, worked perfectly on 3 toons just now.
    • 0
<